ramirex

recopilacion de todo lo que hago en mi vida profesional

Posts Tagged ‘Apache

Problema Apache descarga php al usar usermod

leave a comment »

Cuando al fin configuramos nuestro Apache para que soporte usermod (que cada usuario tenga su public_html), ejecutamos un html y todo nos anda perfecto, pero si ejecutamos un codigo php, Apache directamente quiere descargarlo. La forma es simple y hasta comica..

abren el archivo php5.conf

sudo vim /etc/apache2/mods-available/php5.conf

nos sale los siguientes datos.. comenten las siguientes que estan de color verde

<IfModule mod_php5.c>
    <FilesMatch “\.ph(p3?|tml)$”>
        SetHandler application/x-httpd-php
    </FilesMatch>
    <FilesMatch “\.phps$”>
        SetHandler application/x-httpd-php-source
    </FilesMatch>
    # To re-enable php in user directories comment the following lines
    # (from <IfModule …> to </IfModule>.) Do NOT set it to On as it
    # prevents .htaccess files from disabling it.
   # <IfModule mod_userdir.c>
   #     <Directory /home/*/public_html>
   #         php_admin_value engine Off
   #     </Directory>
   # </IfModule>

</IfModule>

Guardan el archivo modificado y desde la consola reinician el servicio de apache

sudo /etc/init.d/apache2 restart

Anuncios

Written by ramirex

mayo 10, 2012 at 9:55 am

Publicado en General

Tagged with , , ,

MySQL error 10061 conexión remota a MySQL

with one comment

cuando se quire entrar desde una maquina remota a un servidor Mysql nos da un error 10061 y hay que configurar para poder trabajar con un id, para ello hay que hacer la siguiente configurarcion

sudo vim /etc/mysql/my.cnf

buscamos bind-address            = 127.0.0.1 y reeplazamos por 

bind-address            = 0.0.0.0

guardamos el archivo y reiniciamos mysql

sudo /etc/init.d/mysql restart

Written by ramirex

mayo 4, 2012 at 11:55 am

Publicado en java

Tagged with , , , ,

Solución Error 403 Forbidden en Wamp

with 25 comments

Cuando Instalamos WAMP los pasos son muy fáciles, bueno en si es siguiente, siguiente, finalizar y cuando entramos por en navegador del que ahora es el servidor, todo funciona muy bien, prácticamente, no necesita ninguna otra configuración, pero la cara de la moneda cambia cuando queremos entrar desde una maquina de nuestra red y peor aun desde en Internet, el Apache viene preconfigurado, para que no acepte peticiones, pero se soluciona fácilmente modificando el httpd.conf, donde lo que tenemos que hacer es remplazar las siguientes lineas…

Order deny,allow
Deny from all
Allow from 127.0.0.1

por estas lineas:


Order allow,deny
Allow from all

Para apache 2.4.9

cambian la configuracion

<Diretory “c/wamp/www/”>

     #Require local

     Require all granted

</Directory>

reiniciamos los servicios y listo…

pd. Este post lo ago por que cada ves que instalo el Wamp, siempre me olvido de esta configuración.

Written by ramirex

agosto 5, 2011 at 9:24 am

Publicado en Web

Tagged with , , ,